首页 / Windows服务器 / win2012中让IIS同时支持多版本ASP.NET 3.5/4.0/4.5的方法

win2012中让IIS同时支持多版本ASP.NET 3.5/4.0/4.5的方法

Windows 2012系统天然就支持ASP.NET 4.5框架,就像Windows 2008系统默认支持ASP.NET 3.5一样。我们也可以在2012系统中安装3.5框架,让IIS同时支持ASP.NET 2.0/3.5/4.0/4.5多个版本。

Windows 2012系统天然就支持ASP.NET 4.5框架,就像Windows 2008系统默认支持ASP.NET 3.5一样。我们也可以在2012系统中安装3.5框架,让IIS同时支持ASP.NET 2.0/3.5/4.0/4.5多个版本。

注意,这里提到的四个.NET框架版本,其实已经合并为两个。ASP.NET 3.5是.NET 2.0的升级版本,ASP.NET 4.5是.NET 4.0的升级版本。也就是说,当我们需要2.0版本时,把.NET框架调整到3.5即可;同理,当我们需要4.0版本时,把.NET框架调整到4.5即可。

安装准备

本文是以IIS 8.0为例,也适用于IIS 7.0/7.5/8.5版本,但不适用IIS 6.0版本,6.0版本对.NET框架的支持与设置和以后版本有很大区别。我们在安装IIS 8.0的时候,需确保已安装以下应用程序开发模块。

win2012中让IIS同时支持多版本ASP.NET 3.5/4.0/4.5的方法

我们知道,IIS上可以同时支持多网站的访问,即业内人士通常说的虚拟主机。每个虚拟主机都是运行在特定的应用程序池中的,一个程序池中既可以放置一个网站,也可以放置多个网站。ASP.NET版本就是在应用程序池中设置的,同一个程序池中的全部网站则拥有相同的.NET框架。

win2012中让IIS同时支持多版本ASP.NET 3.5/4.0/4.5的方法

设置方法

要测试不同.NET版本的效果,我们可以新建两个网站,并把它们放在不同的应用程序池中。关于新建网站的步骤,这里不再详述,可参考朝暮数据官方博客的其他文章。下面介绍如何修改应用程序池的.NET版本。

打开应用程序池,选择要调整的程序池,再点击右侧操作栏上的“基本设置”。

win2012中让IIS同时支持多版本ASP.NET 3.5/4.0/4.5的方法

在“编辑应用程序池”对话框中,就可以选择.NET Framework版本了。请看下面的图示,虽然只显示了2个版本,但可以支持2.0/3.5/4.0/4.5四种.NET框架,或者您还可以选择“无托管代码”,让程序池完全不支持.NET。

win2012中让IIS同时支持多版本ASP.NET 3.5/4.0/4.5的方法

顺便提一下,应用程序池的关键设置点除了.NET版本外,还有托管管道模式(经典/集成),以及是否启用32位应用程序(默认是64位)。因此,要决定某个应用程序池的基本特性,需同时确定.NET版本、托管模式和32/64位这三个特征。

本文来自网络,不代表我是攻城狮立场,转载请注明出处:https://www.54gcs.cn/os/windowsserver/12650.html

helwo作者

上一篇
下一篇

为您推荐

发表评论

联系我们

联系我们

在线咨询: QQ交谈

邮箱: web@5vo.cn

工作时间:周一至周五,9:00-17:30,节假日休息
关注微信
微信扫一扫关注我们

微信扫一扫关注我们

手机访问
手机扫一扫打开网站

手机扫一扫打开网站

返回顶部
跳至工具栏