首页 / Java / shade解决mybatis包冲突问题

shade解决mybatis包冲突问题

目前有一个项目,A是第三方应用,代码不公开,不能修改,使用的…

目前有一个项目,A是第三方应用,代码不公开,不能修改,使用的是mybatis plugs3.3.1,而当前项目是我们自己的B,它需要用到A里的方法,B里mybatis plugs版本是2.3,目前在使用过程中出现了问题,这两个版本的有些方法,注解都发生了很大的变化 :

mybatis 3.x BaseMapper注解的位置:import com.baomidou.mybatisplus.core.mapper.BaseMapper;
mybatis 2.x BaseMapper注解的位置:import com.baomidou.mybatisplus.mapper.BaseMapper;
这两个版本对于很多注解,接口,方法,类都是不同的,两个版本无法兼容,当我们项目引用A项目之后,就出现A版本里使用mybatis的一些错误,就是方法,类未找到的错误。

shade插件进行解决

我们需要引用a-shade这个项目,它来依赖a,然后在它里使用shade插件对a里的mybatis进行重命名,再由b直接引用a-shade,这时 a里的方法也就有了,并且引用了mybatis的地方都换成了shade开头的包了

shade解决mybatis包冲突问题

实现图

shade解决mybatis包冲突问题

a-shade.jar反编译之后

shade解决mybatis包冲突问题

a-shade项目的shade代码

引用a-shade

打包发布后,B项目直接使用a-shade这个包即可,其它代码不需要修改

总结

到此这篇关于shade解决mybatis包冲突问题的文章就介绍到这了,更多相关shade mybatis包冲突内容请搜索我是攻城狮以前的文章或继续浏览下面的相关文章希望大家以后多多支持我是攻城狮!

本文来自网络,不代表我是攻城狮立场,转载请注明出处:https://www.54gcs.cn/programming/java/88951.html

helwo作者

上一篇
下一篇

为您推荐

发表评论

联系我们

联系我们

在线咨询: QQ交谈

邮箱: web@5vo.cn

工作时间:周一至周五,9:00-17:30,节假日休息
关注微信
微信扫一扫关注我们

微信扫一扫关注我们

手机访问
手机扫一扫打开网站

手机扫一扫打开网站

返回顶部
跳至工具栏