首页 / Java / Vscode中不再支持JDK8的原因分析及解决方案

Vscode中不再支持JDK8的原因分析及解决方案

昨天还用得好好的,今天突然给我说仅支持JDK11以上了,也不…

昨天还用得好好的,今天突然给我说仅支持JDK11以上了,也不能进行正常的代码补全了。

看了一下,是Language Support for Java™ by Red Hat这个拓展更新到0.65.0的原因。

因为Eclipse平台决定将JDK11作为9月发布的最低要求,而vscode是依赖eclipsejdt.ls服务器的,所以需要更新到JDK11。

解决方案1

如果不是必须使用JDK8,可以选择更换为JDK11或更新

解决方案2

官方说可以在settings.json中配置java.configuration.runtimes,这个配置仍然支持Java1.5到14
不过依旧需要安装JDK11,用来启动Java语言服务器,具体的编译版本则可以自行选择

解决方案3

照常使用以前版本,直接选中该拓展的设置C>安装另一个版本C>选择安装的版本:0.64.1

然后关闭拓展更新:
在设置中关闭Extensions: Auto Update

总结

到此这篇关于Vscode中不再支持JDK8的解决方案的文章就介绍到这了,更多相关Vscode不再支持JDK8内容请搜索我是攻城狮以前的文章或继续浏览下面的相关文章希望大家以后多多支持我是攻城狮!

本文来自网络,不代表我是攻城狮立场,转载请注明出处:https://www.54gcs.cn/programming/java/89042.html

helwo作者

上一篇
下一篇

为您推荐

发表评论

联系我们

联系我们

在线咨询: QQ交谈

邮箱: web@5vo.cn

工作时间:周一至周五,9:00-17:30,节假日休息
关注微信
微信扫一扫关注我们

微信扫一扫关注我们

手机访问
手机扫一扫打开网站

手机扫一扫打开网站

返回顶部
跳至工具栏